Blob Blame History Raw
# No proper release-tags, yet.  :(
%global commit 97efd293491ad7ec96a655665339908f2478b3d1
%global shortcommit %(c=%{commit}; echo ${c:0:7})
%global gitdate 20161212
%global git_ver -git%{gitdate}.%{shortcommit}
%global git_rel .git%{gitdate}.%{shortcommit}


Name:		bluez-tools
Version:	0.2.0
Release:	0.3%{?git_rel}%{?dist}
Summary:	A set of tools to manage Bluetooth devices for Linux

License:	GPLv2+
URL:		https://github.com/khvzak/%{name}
Source0:	%{url}/archive/%{commit}.tar.gz#/%{name}-%{version}%{?git_ver}.tar.gz

BuildRequires:	autoconf
BuildRequires:	automake
BuildRequires:	glib2-devel
BuildRequires:	readline-devel

Requires:	bluez%{?_isa}

%description
This was a GSoC'10 project to implement a new command line tools for
bluez (Bluetooth stack for Linux).  It is currently an active open
source project.

The project is implemented in C and uses the D-Bus interface of bluez.

The project is still a work in progress, and not all APIs from Bluez
have been implemented as a part of bluez-tools.  The APIs which have
been implemented in bluez-tools are adapter, agent, device, network
and obex.  Other APIs, such as interfaces for medical devices,
pedometers and other specific APIs have not been ported to bluez-tools.


%prep
%autosetup -n %{name}-%{commit} -p 1
%{_bindir}/autoreconf -fiv


%build
%configure
%make_build


%install
%make_install


%files
%license AUTHORS COPYING
%doc ChangeLog README
%{_bindir}/bt-*
%{_mandir}/man1/bt-*


%changelog
* Wed Mar 01 2017 Björn Esser <besser82@fedoraproject.org> - 0.2.0-0.3.git20161212.97efd29
- Append %%{?git_rel} to Release-tag

* Sun Feb 19 2017 Björn Esser <besser82@fedoraproject.org> - 0.2.0-0.2
- Initial import (rhbz#1424772)

* Sun Feb 19 2017 Björn Esser <besser82@fedoraproject.org> - 0.2.0-0.1
- Initial rpm-release (rhbz#1424772)