Blob Blame History Raw
%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}

%define qt3pkg qt
%if 0%{?fedora} > 8
%define qt3pkg qt3
%endif

Name: aqbanking
Summary: A library for online banking functions and financial data import/export
Version: 3.8.2
Release: 1%{?dist}
# Download is PHP form at http://www.aquamaniac.de/sites/download/packages.php
Source: %{name}-%{version}.tar.gz
Group: System Environment/Libraries
License: GPLv2+
URL: http://www.aquamaniac.de/aqbanking/
Patch1: aqbanking-3.8.2-c++.patch
Patch2: aqbanking-3.7.2-pkgconfig.patch
Patch3: aqbanking-2.1.0-conflict.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
# qbanking
BuildRequires: %{qt3pkg}-devel
# python
BuildRequires: python, PyXML, gmp-devel
BuildRequires: gwenhywfar-devel >= 3.4.1, libofx-devel >= 0.9.0, gettext, libtool
Requires(post): /sbin/ldconfig
Requires(postun): /sbin/ldconfig
Obsoletes: aqhbci <= 1.0.3
Obsoletes: g2banking < %{version}

%description 
The intention of AqBanking is to provide a middle layer between the
program and the various Online Banking libraries (e.g. AqHBCI). The
first backend which is already supported is AqHBCI, a library which
implements a client for the German HBCI (Home Banking Computer
Interface) protocol. Additionally, Aqbanking provides various plugins
to simplify import and export of financial data. Currently there are
import plugins for the following formats: DTAUS (German financial
format), SWIFT (MT940 and MT942).

%package devel
Summary: Development headers for Aqbanking
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
Requires: gwenhywfar-devel
Requires: pkgconfig
# for %{_datadir}/aclocal
Requires: automake
Obsoletes: aqhbci-devel <= 1.0.3
Obsoletes: g2banking-devel < %{version}

%description devel
This package contains aqbanking-config and header files for writing and
compiling programs using Aqbanking.

%package -n qbanking
Summary: Qt bindings for Aqbanking
Group: System Environment/Libraries
Requires: %{name} = %{version}-%{release}
Requires(post): /sbin/ldconfig
Requires(postun): /sbin/ldconfig
Obsoletes: aqhbci-qt-tools <= 1.0.3
Obsoletes: kbanking < %{version}

%description -n qbanking
This package contains the qbanking KDE bindings for the Aqbanking
online banking library.

%package -n qbanking-devel
Summary: Development headers for qbanking
Group: Development/Libraries
Requires: %{name}-devel = %{version}-%{release}
Requires: qbanking = %{version}-%{release}
Requires: %{qt3pkg}-devel
Obsoletes: kbanking-devel < %{version}

%description -n qbanking-devel
This package contains qbanking-config and header files for writing and
compiling programs using the qbanking bindings for Aqbanking.

%package -n python-%{name}
Summary: Python bindings for Aqbanking
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}

%description -n python-%{name}
This package contains python bindings for Aqbanking.

%prep
%setup -q
%patch1 -p1 -b .c++
%patch2 -p1 -b .pkgconfig
%patch3 -p1 -b .conflict

%build
[ -z "$QTDIR" ] && . /etc/profile.d/qt.sh
%{configure} --disable-static \
  --with-kde3-libs=%{_libdir} \
  --enable-libofx \
  --enable-python

make LIBTOOL=/usr/bin/libtool

%install
rm -rf $RPM_BUILD_ROOT

make DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool install

find $RPM_BUILD_ROOT -name *.la -exec rm -f {} \;
find $RPM_BUILD_ROOT -name *.a -exec rm -f {} \;

cd tutorials
make clean
rm -rf .deps
rm -f Makefile*
cd ..

mkdir -p $RPM_BUILD_ROOT/%{_datadir}/doc/%{name}-%{version}
mv $RPM_BUILD_ROOT/%{_datadir}/doc/{aqbanking,aqhbci} $RPM_BUILD_ROOT/%{_datadir}/doc/%{name}-%{version}
mv AUTHORS README COPYING ChangeLog NEWS $RPM_BUILD_ROOT/%{_datadir}/doc/%{name}-%{version}
%find_lang %{name}

%clean
rm -rf $RPM_BUILD_ROOT

%post -p /sbin/ldconfig

%postun -p /sbin/ldconfig

%post -n qbanking -p /sbin/ldconfig

%postun -n qbanking -p /sbin/ldconfig

%files -f %{name}.lang
%defattr(-,root,root)
%doc %{_datadir}/doc/%{name}-%{version}
%{_libdir}/libaq*.so.*
%{_libdir}/aqbanking
%exclude %{_libdir}/aqbanking/plugins/*/debugger
%exclude %{_libdir}/aqbanking/plugins/*/frontends/qbanking
%exclude %{_libdir}/aqbanking/plugins/*/wizards
%{_libdir}/gwenhywfar/*
%{_datadir}/aqbanking
%exclude %{_datadir}/aqbanking/frontends/*
%exclude %{_datadir}/aqbanking/i18n
%{_bindir}/*-tool3

%files devel
%defattr(-,root,root)
%doc doc/0[12]* tutorials
%{_bindir}/hbcixml3
%{_bindir}/aq*-config
%{_libdir}/libaq*.so
%{_includedir}/aq*
%{_libdir}/pkgconfig/*
%{_datadir}/aclocal/aq*

%files -n qbanking
%defattr(-,root,root)
%{_bindir}/qb-help6
%{_libdir}/libqbanking.so.*
%{_libdir}/aqbanking/plugins/*/debugger
%{_libdir}/aqbanking/plugins/*/frontends/qbanking
%{_libdir}/aqbanking/plugins/*/wizards
%{_datadir}/aqbanking/i18n
%{_datadir}/aqbanking/frontends/qbanking

%files -n qbanking-devel
%defattr(-,root,root)
%{_includedir}/qbanking
%{_libdir}/libqbanking.so

%files -n python-%{name}
%defattr(-,root,root)
%{python_sitelib}/%{name}

%changelog
* Thu Mar  5 2009 Bill Nottingham <notting@redhat.com> - 3.8.2-1
- update to 3.8.2-1

* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.7.2-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild

* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 3.7.2-2
- Rebuild for Python 2.6

* Tue Sep  9 2008 Bill Nottingham <notting@redhat.com> - 3.7.2-1
- update to 3.7.2
- obsolete the no-longer-existing g2banking/kbanking packages

* Tue Mar 25 2008 Rex Dieter <rdieter@fedoraproject.org> - 2.3.3-3
- s/qt-devel/qt3-devel/ (f9+)
- qbanking-devel: Req: qt3-devel
- kbanking-devel: Req: kdelibs3-devel
- omit extraneous: Req: pkgconfig

* Thu Feb 14 2008 Bill Nottingham <notting@redhat.com> - 2.3.3-2
- rebuild for gcc-4.3

* Tue Jan 15 2008 Bill Nottingham <notting@redhat.com> - 2.3.3-1
- update to 2.3.3

* Wed Dec 19 2007 Bill Nottingham <notting@redhat.com> - 2.3.2-4
- kbanking-devel needs to require qbanking-devel (#426265)

* Tue Oct 30 2007 Bill Nottingham <notting@redhat.com> - 2.3.2-3
- fix multilib conflicts (#340671)

* Wed Aug 29 2007 Bill Nottingham <notting@redhat.com> - 2.3.2-2
- Rebuild for selinux ppc32 issue.
- fix build with current glibc/headers

* Fri Aug  3 2007 Bill Nottingham <notting@redhat.com>
- tweak license tag

* Wed Jul 11 2007 Bill Nottingham <notting@redhat.com> - 2.3.2-1
- update to 2.3.2

* Mon Jun 25 2007 Bill Nottingham <notting@redhat.com> - 2.2.9-3
- fix some build bogosity

* Wed Jun 20 2007 Bill Nottingham <notting@redhat.com> - 2.2.9-2
- add a dist tag

* Mon Mar 19 2007 Bill Nottingham <notting@redhat.com> - 2.2.9-1
- update to 2.2.9

* Wed Jan 17 2007 Bill Nottingham <notting@redhat.com> - 2.1.0-14
- fix docdir, obsoletes for aqhbci-devel, and %%clean

* Tue Jan 16 2007 Bill Nottingham <notting@redhat.com> - 2.1.0-13
- fix docs
- add PyXML buildreq

* Mon Jan 15 2007 Bill Nottingham <notting@redhat.com> - 2.1.0-12
- fix missing %%defattrs
- fix %%excludes
- other cleanups from review
- use %%{_python_sitelib}
- require automake
- twiddle aqhbci obsoletes

* Sat Jan 13 2007 Bill Nottingham <notting@redhat.com> - 2.1.0-11
- split into a variety of packages

* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 2.1.0-10
- rebuild for python 2.5

* Thu Sep  7 2006 Bill Nottingham <notting@redhat.com> - 2.1.0-9
- rebuild for fixed debuginfo (#205248)

* Fri Sep  1 2006 Bill Nottingham <notting@redhat.com> - 2.1.0-8
- fix multilib conficts (#205204)

* Mon Aug 28 2006 Bill Nottingham <notting@redhat.com> - 2.1.0-4
- rebuild against latest libofx

* Tue Aug  1 2006 Bill Nottingham <notting@redhat.com> - 2.1.0-3
- reenable visibility

* Fri Jul 14 2006 Bill Nottingham <notting@redhat.com> - 2.1.0-2
- port *-config to pkgconfig
- don't use -fvisibility=hidden

* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.1.0-1.1
- rebuild

* Tue Jul 11 2006 Bill Nottingham <notting@redhat.com> - 2.1.0-1
- update to 2.1.0

* Mon Jun 12 2006 Bill Nottingham <notting@redhat.com> - 1.8.1beta-5
- buildreq autoconf, libtool

* Tue May 30 2006 Bill Nottingham <notting@redhat.com> - 1.8.1beta-4
- add gettext buildreq (#193348)

* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.8.1beta-3.1
- bump again for double-long bug on ppc(64)

* Tue Feb 07 2006 Karsten Hopp <karsten@redhat.de> 1.8.1beta-3
- buildrequire libofx-devel instead of libofx (pulls in libofx)

* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.8.1beta-2.1
- rebuilt for new gcc4.1 snapshot and glibc changes

* Sun Jan 22 2006 Bill Nottingham <notting@redhat.com> 1.8.1beta-2
- add an obsolete (#178554)

* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
- rebuilt

* Mon Mar  7 2005 Bill Nottingham <notting@redhat.com> 1.0.4beta-2
- rebuild

* Wed Feb  9 2005 Bill Nottingham <notting@redhat.com> 1.0.4beta-1
- initial packaging, adopt upstream specfile