Blob Blame History Raw
Name:          apache-sshd
Version:       0.7.0
Release:       5%{?dist}
Summary:       Apache SSHD
License:       ASL 2.0
URL:           http://mina.apache.org/sshd-project/
# Take into account that this URL will take you to a mirror
# system, so you will need to use a browser to get the real file:
Source0:       http://www.apache.org/dyn/closer.cgi/mina/sshd/%{version}/%{name}-%{version}-src.tar.gz
# User version of bouncycastle for JDK6:
Patch0:        %{name}-use-bouncycastle-for-jdk6.patch
# Use tomcat-coyote instead of unavailable tomcat-apr
Patch1:        %{name}-use-tomcat-coyote.patch

BuildArch:     noarch

BuildRequires: java-devel
BuildRequires: maven-local
BuildRequires: maven-plugin-bundle

BuildRequires: apache-mina >= 2.0.4
BuildRequires: jzlib >= 1.1.0
BuildRequires: bouncycastle >= 1.46
BuildRequires: tomcat-lib >= 7.0.25

%description
Apache SSHD is a 100% pure java library to support the SSH protocols on both
the client and server side.

%package javadoc
Summary:       Javadoc for %{name}

%description javadoc
This package contains javadoc for %{name}.


%prep
%setup -q
%patch0 -p1
%patch1 -p1

# Build the core only
%pom_disable_module assembly src
%pom_disable_module sshd-pam src
# Dont try to download the license file
%pom_remove_plugin :maven-remote-resources-plugin src

%build

# In the tarball distributed by Apache the source code is inside the srv
# directory:
cd src

# Skip the tests as they don't run correctly with the current
# version of the jzlib compression library that we have in the
# distribution at the moment:
%mvn_build -f -- -Dproject.build.sourceEncoding=UTF-8

%install
cd src
%mvn_install

%files -f src/.mfiles
%doc src/LICENSE.txt
%doc src/NOTICE.txt

%files javadoc -f src/.mfiles-javadoc
%doc src/LICENSE.txt
%doc src/NOTICE.txt

%changelog
* Mon Aug 05 2013 gil cattaneo <puntogil@libero.it> 0.7.0-5
- rebuilt rhbz#991979
- swith to Xmvn
- adapt to new guideline
- use pom macros
- remove rpmlint warnings

* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild

* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild

* Wed Feb 06 2013 Java SIG <java-devel@lists.fedoraproject.org> - 0.7.0-2
- Update for https://fedoraproject.org/wiki/Fedora_19_Maven_Rebuild
- Replace maven BuildRequires with maven-local

* Thu Jul 26 2012 Juan Hernandez <juan.hernandez@redhat.com> - 0.7.0-1
- Update to upstream 0.7.0

* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild

* Tue Feb 14 2012 Juan Hernandez <juan.hernandez@redhat.com> 0.6.0-2
- Corrected the source URL

* Sun Feb 12 2012 Juan Hernandez <juan.hernandez@redhat.com> 0.6.0-1
- Initial packaging