Blob Blame History Raw
Name:           aether-ant-tasks
Epoch:          1
Version:        0.9
Release:        0.1.SNAPSHOT%{?dist}
Summary:        Ant tasks using Aether to resolve, install and deploy artifacts
Group:          Development/Libraries
BuildArch:      noarch

License:        EPL
URL:            http://www.eclipse.org/aether
# git clone http://git.eclipse.org/gitroot/aether/aether-ant.git
# tar -cJf aether-ant.tar.xz aether-ant
Source0:        aether-ant.tar.xz
Source1:        http://www.eclipse.org/legal/epl-v10.html

BuildRequires:  maven-local
BuildRequires:  ant-testutil
BuildRequires:  mvn(org.apache.maven:maven-aether-provider)
BuildRequires:  mvn(org.apache.maven:maven-settings-builder)
BuildRequires:  mvn(org.codehaus.plexus:plexus-component-annotations)
BuildRequires:  mvn(org.codehaus.plexus:plexus-interpolation)
BuildRequires:  mvn(org.eclipse.aether:aether-api)
BuildRequires:  mvn(org.eclipse.aether:aether-util)
BuildRequires:  mvn(org.eclipse.aether:aether-impl)
BuildRequires:  mvn(org.eclipse.aether:aether-connector-asynchttpclient)
BuildRequires:  mvn(org.eclipse.aether:aether-connector-file)
BuildRequires:  mvn(org.eclipse.aether:aether-test-util)
BuildRequires:  mvn(org.sonatype.forge:forge-parent)

%description
The Aether Ant Tasks enable build scripts for Apache Ant 1.7+ to use Sonatype
Aether to resolve dependencies and install and deploy locally built artifacts.

%package javadoc
Summary:        Javadocs for %{name}
Group:          Documentation

%description javadoc
This package contains the API documentation for %{name}.

%prep
%setup -q -n aether-ant
cp -p %{SOURCE1} LICENSE

# Not sure what the deal is with tesla...
sed -i -e 's@io\.tesla@org.apache@g' pom.xml

# Use junit since junit-dep is obselete and equivilent to junit since 4.11
sed -i -e 's@junit-dep@junit@g' pom.xml

# Fix build deps
%pom_add_dep "org.codehaus.plexus:plexus-component-api"
%pom_remove_dep "org.sonatype.sisu:sisu-inject-plexus"
%pom_remove_plugin ":maven-shade-plugin"
%pom_remove_plugin ":maven-enforcer-plugin"

%build
# Some tests require internet connectivity, so ignore failures
%mvn_build -- -Dmaven.test.failure.ignore=true

%install
%mvn_install

%files -f .mfiles
%doc LICENSE README.md

%files javadoc -f .mfiles-javadoc
%doc LICENSE

%changelog
* Mon Jul 29 2013 Mat Booth <fedora@matbooth.co.uk> - 1:0.9-0.1.SNAPSHOT
- Upstream has moved to Eclipse, update to upstream 0.9-SNAPSHOT
- Run tests now all deps are in Fedora
- Migrate to Eclipse Aether, fixes rhbz #985700

* Tue May 14 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.0-0.8.SNAPSHOT
- Add missing BR: maven-shade-plugin

* Tue May  7 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.0-0.7.SNAPSHOT
- Replace BR with mvn-style virtual packages
- Resolves: rhbz#958156

* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-0.6.SNAPSHOT
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild

* Wed Feb 06 2013 Java SIG <java-devel@lists.fedoraproject.org> - 1.0-0.5.SNAPSHOT
- Update for https://fedoraproject.org/wiki/Fedora_19_Maven_Rebuild
- Replace maven BuildRequires with maven-local

* Wed Jan  9 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.0-0.4.SNAPSHOT
- Bump release tag

* Tue Jan  8 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.0-0.3.SNAPSHOT
- Build with xmvn

* Mon Sep 17 2012 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.0-0.2.SNAPSHOT
- Install LICENSE files

* Mon Apr 30 2012 Mikolaj Izdebski <mizdebsk@redhat.com> 1.0-0.1.SNAPSHOT
- Initial packaging.