Blob Blame History Raw
Summary:   Command-line program to read and set MPEG-4 tags compatible with iPod/iTunes 
URL:       http://atomicparsley.sourceforge.net/
Name:      AtomicParsley
Version:   0.9.0
Release:   13%{?dist}
License:   GPLv2+
Group:     Applications/Multimedia
Source0:   http://downloads.sourceforge.net/project/atomicparsley/atomicparsley/%{name}%20v%{version}/%{name}-source-%{version}.zip
Patch0:    %{name}-fix_bad_math.patch



%description
AtomicParsley is a command line program for reading, parsing and setting
tags and meta-data into MPEG-4 files supporting these styles of meta-data:

* iTunes-style meta-data into .mp4, .m4a, .m4p, .m4v, .m4b files
* 3gp-style assets (3GPP TS 26.444 version 6.4.0 Release 6 specification
  conforming) in 3GPP, 3GPP2, MobileMP4 & derivatives
* ISO copyright notices at movie & track level for MPEG-4 & derivative files
* uuid private user extension text & file embedding for MPEG-4 & derivative
  files


%prep
# The source zip file includes a top level directory called __MACOSX which doesn't
# get removed by %%clean, so in a multiple RPM build scenario this directory will
# not get removed, making a subsequent RPM build fails in the unzipping process.
# We will (try to) remove this useless leftover directory and the new one that
# will be generated by unzipping right now to avoid problems in subsequent RPM
# builds of the same package and to keep the build directory clean.
rm -rf __MACOSX
%setup -q -n "%{name}-source-%{version}"
rm -rf ../__MACOSX
chmod a-x *.cpp *.h
%patch0

sed -i 's/-O2/$OPTFLAGS/g;' build
sed -i 's/g++/$CXX/g;' build
sed -i '1aset -e' build

%build
CXX="%__cxx" \
OPTFLAGS="%{optflags} -Wall -Wno-parentheses -Wno-unused-result -Wno-write-strings -Wno-deprecated -fno-strict-aliasing" \
./build

%install
install -D -m0755 AtomicParsley "%{buildroot}%{_bindir}/AtomicParsley"


%files

%doc COPYING "AP buglist.txt" "Using AtomicParsley.rtf"
%{_bindir}/AtomicParsley

%changelog
* Tue Jan 28 2013 Avi Alkalay <avi@unix.sh> 0.9.0-13
- Reduced warnings
- Adapted SPEC to build on Fedora 20

* Mon Oct 01 2012 Avi Alkalay <avi@unix.sh> 0.9.0-12
- Editing with comments from https://bugzilla.redhat.com/show_bug.cgi?id=800284#c7

* Mon Oct 01 2012 Avi Alkalay <avi@unix.sh> 0.9.0-11
- Editing with comments from https://bugzilla.redhat.com/show_bug.cgi?id=800284#c5

* Tue Sep 25 2012 Avi Alkalay <avi@unix.sh> 0.9.0-10
- Editing with comments from https://bugzilla.redhat.com/show_bug.cgi?id=800284#c3

* Fri Mar 02 2012 Avi Alkalay <avi@unix.sh> 0.9.0-9
- Editing with comments from https://bugzilla.rpmfusion.org/show_bug.cgi?id=2190#c1

* Wed Feb 22 2012 Avi Alkalay <avi@unix.sh> 0.9.0-7
- RPM and patches adapted and built for Fedora 16 based on Madriva SRPM

* Thu Jul 22 2010 pascal@links2linux.de
- initial package (0.9.0)