Blob Blame History Raw
# Conditional for release and snapshot builds. Uncomment for release-builds.
%global rel_build 1

# Setup _pkgdocdir if not defined already.
%{!?_pkgdocdir:%global _pkgdocdir	%{_docdir}/%{name}-%{version}}

# Settings used for build from snapshots.
%{!?rel_build:%global commit		2fef5a482227ef2b2189fcf2934d0ee132141115}
%{!?rel_build:%global commit_date	20141201}
%{!?rel_build:%global shortcommit	%(c=%{commit};echo ${c:0:7})}
%{!?rel_build:%global gitver		git%{commit_date}-%{shortcommit}}
%{!?rel_build:%global gitrel		.git%{commit_date}.%{shortcommit}}

# Proper naming for the tarball from github.
%global gittar %{name}-%{version}%{!?rel_build:-%{gitver}}.tar.gz

Name:			2048-cli
Version:		0.8
Release:		2%{?gitrel}%{?dist}
Summary:		The game 2048 for your Linux terminal
%{?el5:Group:		Amusements/Games}

License:		MIT
URL:			https://github.com/Tiehuis/%{name}
# Sources for release-builds.
%{?rel_build:Source0:	%{url}/archive/v%{version}.tar.gz#/%{gittar}}
# Sources for snapshot-builds.
%{!?rel_build:Source0:	%{url}/archive/%{commit}.tar.gz#/%{gittar}}

%{?el5:BuildRoot:	%(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)}
BuildRequires:		ncurses-devel

%description
A cli version of the game 2048 for your Linux terminal.


%package nocurses
Summary:		The game 2048 for your Linux terminal (non-ncurses)
%{?el5:Group:		Amusements/Games}

%description nocurses
A non-ncurses cli version of the game 2048 for your Linux terminal.


%prep
%setup -q%{!?rel_build:n %{name}-%{commit}}


%build
%{__make} %{?_smp_mflags} 2048 2048nc				\
	CFLAGS='%{optflags}' LDFLAGS='%{?__global_ldflags}'


%install
%{?el5:%{__rm} -rf %{buildroot}}

# There is no install-target in Makefile.
%{__mkdir} -p %{buildroot}%{_bindir} %{buildroot}%{_pkgdocdir}
%{__install} -pm 0755 2048 2048nc %{buildroot}%{_bindir}
%{__install} -pm 0644 LICENSE README.md %{buildroot}%{_pkgdocdir}


%{?el5:%clean}
%{?el5:%{__rm} -rf %{buildroot}}


%files
%doc %{_pkgdocdir}
%{_bindir}/2048

%files nocurses
%doc %{_pkgdocdir}
%{_bindir}/2048nc


%changelog
* Thu Dec 04 2014 Björn Esser <bjoern.esser@gmail.com> - 0.8-2
- dropped Patch0 (#1170231)
- some minor readability clean-up

* Wed Dec 03 2014 Björn Esser <bjoern.esser@gmail.com> - 0.8-1
- initial rpm-release (#1170231)