lkundrak / rpms / ddclient

Forked from rpms/ddclient 4 years ago
Clone
Blob Blame History Raw
Name:           ddclient
Version:        3.6.3
Release:        4
Summary:        Client to update dynamic DNS host entries

Group:          System Environment/Daemons
License:        GPL
URL:            http://burry.ca:4141/ddclient
Source:         http://members.rogers.com/ddclient/pub/%{name}-%{version}.tar.gz
Source2:        ddclient.initscript
Source3:        ddclient.sysconfig
# Patch hardcodes cache location to /var/cache.
# This is reflected in install section below.
Patch:          ddclient.cache.patch
BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch:      noarch

%description
ddclient is a Perl client used to update dynamic DNS entries for accounts
on many dynamic DNS services.


%prep
%setup -q
%patch -p1


%build


%install
rm -rf $RPM_BUILD_ROOT

mkdir -p $RPM_BUILD_ROOT%{_sbindir}
mkdir -p $RPM_BUILD_ROOT%{_initrddir}
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
install -p ddclient $RPM_BUILD_ROOT%{_sbindir}
install -p sample-etc_ddclient.conf $RPM_BUILD_ROOT%{_sysconfdir}/ddclient.conf
install -p %{SOURCE2} $RPM_BUILD_ROOT%{_initrddir}/ddclient
install -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/ddclient
mkdir -p $RPM_BUILD_ROOT/var/cache
touch $RPM_BUILD_ROOT/var/cache/ddclient.cache


%clean
rm -rf $RPM_BUILD_ROOT


%post
/sbin/chkconfig --add ddclient
touch /var/cache/ddclient.cache
chmod 0600 /var/cache/ddclient.cache

%preun
if [ $1 -eq 0 ]; then
        /sbin/service ddclient stop > /dev/null 2>&1
        /sbin/chkconfig --del ddclient
fi


%files
%defattr(-,root,root,-)
%doc README* COPYING COPYRIGHT
%doc %attr(0644, root, root) sample*
%{_sbindir}/ddclient
%config(noreplace) %attr(0600,root,root) %{_sysconfdir}/ddclient.conf
%config(noreplace) %{_sysconfdir}/sysconfig/ddclient
%ghost %attr(0600, root, root) /var/cache/ddclient.cache
%{_initrddir}/ddclient


%changelog
* Mon Apr 05 2004 Toshio Kuratomi <toshio[+]tiki-lounge.com> - 0:3.6.3-0.fdr.4.fc1
- Fix %%doc %%attr ownership
- Touch the cache file in %post

* Mon Sep 08 2003 Michael Schwendt <mschwendt[AT]users.sf.net> - 0:3.6.3-0.fdr.3
- Add own Fedora-style initscript and /etc/sysconfig/ddclient file.
- Fix file permissions of config file and example files.
- Since ddclient.cache.patch uses hardcoded /var, don't use
  %%_localstatedir in spec file either.

* Sun Sep 07 2003 Thomas Vander Stichele <thomas at apestaart dot org>
- 0:3.6.3-0.fdr.2: fixed ghostness of cache file