Blob Blame History Raw
%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}

Name:          python-rpmfluff
Version:       0.3
Release:       5%{?dist}
Summary:       Lightweight way of building RPMs, and sabotaging them
License:       GPLv2
Group:         Development/Tools
URL:           https://fedorahosted.org/rpmfluff/
Source0:       https://fedorahosted.org/releases/r/p/rpmfluff/rpmfluff-%{version}.tar.bz2
BuildRoot:     %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch:     noarch
BuildRequires: python
BuildRequires: python-devel
BuildRequires:  python-setuptools-devel
#BuildRequires:  python-setuptools   # For Fedora < 8
Requires:      python


%description
rpmfluff provides a python library for building RPM packages, and
sabotaging them so they are broken in controlled ways.

It is intended for use when validating package analysis tools such as RPM lint.
It can also be used to construct test cases for package management software
such as rpm and yum.


%prep
%setup -q -n rpmfluff-%{version}


%build
CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build


%install
rm -rf $RPM_BUILD_ROOT
%{__python} setup.py install --skip-build --root $RPM_BUILD_ROOT


%clean
rm -rf $RPM_BUILD_ROOT


%files
%defattr(-,root,root,-)
%doc README
%doc LICENSE
%{python_sitelib}/rpmfluff.py*
%{python_sitelib}/rpmfluff*.egg-info


%changelog
* Fri Feb 12 2010 Jan Hutar <jhutar@redhat.com> - 0.3-5
- Now version is in the separate file

* Thu Jan 26 2010 Jan Hutar <jhutar@redhat.com> - 0.3-4
- Fix for deprecated popen2 module

* Thu Jan 7 2010 Jan Hutar <jhutar@redhat.com> - 0.3-3
- Moved to use EGGs for distribution

* Mon Dec 21 2009 Jan Hutar <jhutar@redhat.com> - 0.3-2
- Added separate LICENSE file

* Fri Dec 18 2009 Jan Hutar <jhutar@redhat.com> - 0.3-1
- New version, first attempt to get to Fedora

* Tue Jul 08 2008 Jan Hutar <jhutar@redhat.com> - 0.1-1
- Initial version
- spec-file based on python-html2text.spec